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Visual Foxpro 6.0: Importing and Exporting data using the import wizard 

In Visual FoxPro 6.0, you can use the Import Wizard to import data from external 

sources such as other databases, spreadsheets, and text files. The Import Wizard 

allows you to specify the source and format of the data, as well as the destination 

table in your database. 

To access the Import Wizard in Visual FoxPro 6.0, go to File > Import and select 

the type of file that you want to import. Then you will be prompted to select the file 

you want to import and the table you want to import it into. Once you have selected 

the source file and destination table, the Import Wizard will guide you through the 

process of mapping the fields from the source file to the fields in the destination 

table. 

Exporting data from Visual FoxPro 6.0 can be done in a similar way, by using the 

Export Wizard. To access the Export Wizard, go to File > Export and select the table 

or query that you want to export. You will then be prompted to select the destination 

file and format and to specify any options such as field delimiters and text qualifiers. 

Once you have specified the options, the Export Wizard will export the data to the 

specified file and format. 

 

It's worth mentioning that the import and export feature in Visual FoxPro 6.0 can be 

used to transfer data between different types of files and databases, but the feature is 

quite limited compared to more recent versions or other database management 

systems. 

Visual Foxpro 6.0: Editing text, Edit menu, Format menu, Spelling tool, 

In Visual FoxPro 6.0, you can edit the text using the Edit menu and the Format menu. 

The Edit menu includes options such as Cut, Copy, Paste, and Undo, which allow 

you to manipulate text in a variety of ways. The Format menu includes options such 

as Font, Size, and Color, which allow you to change the appearance of the text. 
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The Edit menu also includes a Spelling tool that can be used to check the spelling of 

the text. The spelling tool will check the text for misspelled words and provide 

suggestions for the correct spelling. To access the spelling tool, go to the Edit menu 

and select Check Spelling. 

Visual FoxPro 6.0 is not a text editor, it's a database management system, the text 

editing features are quite basic compared to a more recent versions or other text 

editors. 

Visual Foxpro 6.0: Object Linking and Embedding 

In Visual FoxPro 6.0, Object Linking and Embedding (OLE) is a feature that allows 

you to link or embed objects from other applications into a Visual FoxPro form or 

report. OLE allows you to insert and edit objects such as documents, images, and 

charts from other applications, such as Microsoft Word, Excel, or PowerPoint, 

directly into a Visual FoxPro form or report. 

When you link an object to a Visual FoxPro form or report, a reference to the object 

is created, and the object remains in its original application. When you embed an 

object into a Visual FoxPro form or report, a copy of the object is inserted into the 

form or report, and the object is stored within the Visual FoxPro application. 

To insert an OLE object into a form or report, you can use the Insert Object command 

on the Insert menu, or you can use the OLE Control tool on the Toolbox. 

It's worth mentioning that OLE is an old technology that has been replaced by newer 

technologies such as Object Packager, ActiveX, and COM, which are supported in 

more recent versions of Visual FoxPro. 

Visual Foxpro 6.0: Creating files, Running the Program, input/output, 

variables, simple output using'?' Command, Getting input from the User 

In Visual FoxPro 6.0, you can create files by using the File > New command and 

then selecting the type of file you want to create, such as a table, form, or report. 

You can also use the Create Table, Create Form, and Create Report commands on 

the File menu. 

Once you have created the files, you can run the program by using the File > Run 

command, or by pressing the F5 key. 
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In Visual FoxPro, you can use the Input/Output commands to read and write data to 

files. The Input command is used to read data from a file, and the Output command 

is used to write data to a file. 

You can also use variables to store and manipulate data in your program. Variables 

in Visual FoxPro 6.0 can be of different types such as character, integer, and logical. 

To print simple output using the '?' command, you can use the command in the 

Command Window or in the code, followed by the variable or string you want to 

output. For example, ? "Hello World" 

To get input from the user, you can use the Input command in the Command Window 

or in the code, followed by the variable you want to store the input in. For example, 

INPUT "What is your name? ", name 

It's worth mentioning that Visual FoxPro 6.0 has a built-in development environment 

that allows you to create, edit, and run programs, but this version is quite old and has 

been replaced by more recent versions of Visual FoxPro, and other development 

environments such as Visual Studio. 

Visual FoxPro 6.0: @.....SAY...GET command, picture clauses, 

In Visual FoxPro 6.0, the @.....SAY...GET command is used to display a message 

on the screen and to get input from the user. The command has the following syntax: 

@nRow, nCol SAY message [GET variable] 

The @nRow, nCol specifies the position of the message on the screen, where nRow 

is the row number and nCol is the column number. The SAY keyword is used to 

display the message on the screen, and the GET keyword is used to get input from 

the user and store it in the specified variable. 

For example, the following command will display the message "Enter your name:" 

at the position (5,5) on the screen and store the input in the "name" variable: 

@5,5 SAY "Enter your name: " GET name 

In Visual FoxPro 6.0, the PICTURE clause is used to specify the format of a field 

when it's displayed on a form or a report. The PICTURE clause is usually used with 

the format command or the DISPLAY command. The syntax of the PICTURE 

clause is: 
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PICTURE "picture_string" 

Where "picture_string" is a string that specifies the format of the field. For example, 

the following command will format a field called "price" as currency with 2 decimal 

places: 

FORMAT price PICTURE "CURRENCY" 

It's worth mentioning that the @.....SAY...GET command and the PICTURE clause 

are part of the FoxPro language which is a programming language and a database 

management system, They're not available in more recent versions of Visual FoxPro 

and other development environments, it's recommended to use the more recent 

features and commands that are available in the environment you're working with. 

Visual FoxPro 6.0: Looping, Selection, EXIT, and LOOP, procedures and 

parameters 

In Visual FoxPro 6.0, looping is a programming construct that allows you to repeat 

a block of code a specified number of times. Visual FoxPro 6.0 has several looping 

constructs, such as the FOR loop, the DO WHILE loop, and the DO CASE loop. 

Selection is a way to specify a block of code to execute based on certain conditions. 

Visual FoxPro 6.0 has several selection constructs such as the IF-ELSE statement, 

SELECT CASE statement and the DO CASE statement. 

The EXIT and LOOP commands are used to control the flow of a loop. The EXIT 

command is used to exit a loop prematurely, and the LOOP command is used to 

return to the beginning of the loop. 

Procedures and parameters are used to organize and reuse code in Visual FoxPro 

6.0. Procedures are blocks of code that can be called by other parts of the program, 

and parameters are values that can be passed to a procedure when it's called. 

To define a procedure in Visual FoxPro 6.0, you use the PROCEDURE command, 

followed by the name of the procedure and the parameters. For example: 

PROCEDURE MyProcedure (param1, param2) *** code here ENDPROC 

To call a procedure, you use the name of the procedure followed by the values for 

the parameters. For example: 

MyProcedure (val1, val2) 
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It's worth mentioning that Visual FoxPro 6.0 is an old version and is not supported 

anymore. If you are planning to work with loops, selections, procedures, and 

parameters, it's recommended to use a more recent version of Visual FoxPro or other 

programming languages that have more advanced features and support. 

Visual FoxPro: scope of variables and passing parameters 

 

In Visual FoxPro, the scope of a variable determines where in the program the 

variable can be accessed and modified. There are three types of variable scope in 

Visual FoxPro: local, private, and public. 

• Local variables are defined within a procedure or a function and can only be 

accessed within that procedure or function. They are not accessible outside of 

the procedure or function. 

• Private variables are defined at the class level and can be accessed within the 

class, but not outside of it. 

• Public variables are defined at the project or application level and can be 

accessed from any part of the program. 

When passing parameters to a procedure or function in Visual FoxPro, you can use 

either pass-by-value or pass-by-reference. 

• Pass-by-value means that a copy of the value of the parameter is passed to the 

procedure or function, and any changes made to the parameter within the 

procedure or function do not affect the original value outside of the procedure 

or function. 

• Pass-by-reference means that a reference to the memory location of the 

parameter is passed to the procedure or function, and any changes made to the 

parameter within the procedure or function are reflected in the original value 

outside of the procedure or function. 

In Visual FoxPro, by default, variables are passed by reference, but you can use the 

keyword "BYVAL" in the function or procedure definition to pass a variable by 

value. 

It's worth mentioning that Visual FoxPro is an old version and is not supported 

anymore. If you are planning to work with variable scope and passing parameters, 
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it's recommended to use a more recent version of Visual FoxPro or other 

programming languages that have more advanced features and support. 

 

User-Defined Functions, using the Menu Designer, 

using the project manager 

In Visual FoxPro 6.0, user-defined functions are blocks of code that you can create 

and reuse in your program. They can take one or more parameters, perform a specific 

task, and return a value. To create a user-defined function, you can use the 

FUNCTION command, followed by the name of the function and the parameters, 

and then the code that the function will execute. Once you have defined the function, 

you can call it in your program by using the name of the function followed by the 

values for the parameters. 

The Menu Designer is a tool in Visual FoxPro 6.0 that allows you to create and 

customize the menus in your program. You can use the Menu Designer to add, 

remove, and modify menu items and submenus, as well as to assign commands and 

procedures to menu items. 

The Project Manager is a tool in Visual FoxPro 6.0 that allows you to organize and 

manage the files and resources in your program. You can use the Project Manager 

to add and remove files, set properties for files, and create and edit groups of files. 

You can also use the Project Manager to set options for your program, such as the 

startup form, and to create and edit the program's documentation. 

It's worth mentioning that Visual FoxPro 6.0 is an old version and is not supported 

anymore. If you are planning to work with user-defined functions, menu designers, 

and project manager, it's recommended to use a more recent version of Visual 

FoxPro or other development environments that have more advanced features and 

support. 

Techniques of writing efficient FoxPro programming codes. 

There are several techniques that can be used to write efficient FoxPro programming 

code, some of them are: 

1. Proper indexing: Proper indexing of tables can greatly improve the 

performance of your FoxPro program, especially when working with large 

amounts of data. 
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2. Use of SET command: Use the SET command to configure various options 

that can affect performance, such as the buffer size, the lock scheme, and the 

optimization level. 

3. Use of SELECT and USE commands: Use the SELECT and USE commands 

to open only the tables and indexes that are needed for the current task, rather 

than opening all tables and indexes at the start of the program. 

4. Use of SET RELATION command: Use the SET RELATION command to 

establish relationships between tables, which can improve the performance of 

queries and joins. 

5. Use of commands like LOCATE, SEEK, and FIND: Use commands like 

LOCATE, SEEK, and FIND to search for data in tables instead of scanning 

the entire table. 

6. Use of SET FILTER command: Use the SET FILTER command to filter data 

in tables, which can improve the performance of queries and reports. 

7. Use of the APPEND FROM command: Use the APPEND FROM command 

 

create a report using the report wizard 

The Report Wizard is a tool in Visual FoxPro 6.0 that helps you to create reports 

quickly and easily. To create a report using the Report Wizard, you can follow these 

steps: 

1. From the File menu, select New and then Report. 

2. In the Report Wizard dialog box, select the table or query that you want to use 

as the data source for the report. 

3. Select the fields that you want to include in the report and arrange them in the 

order that you want them to appear. 

4. Select the layout and style for the report, such as the font, color, and 

alignment. 

5. Select any grouping or sorting options that you want to apply to the report. 

6. Select any filters or calculated fields that you want to include in the report. 

7. Preview the report and make any necessary adjustments. 

8. Save the report and give it a name. 

It's worth mentioning that Visual FoxPro 6.0 is an old version and is not supported 

anymore. If you are planning to work with report wizard, it's recommended to use a 

more recent version of Visual FoxPro or other reporting tools that have more 

advanced features and support. 
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create a form using the form wizard 

  The Form Wizard is a tool in Visual FoxPro 6.0 that helps you to create forms 

quickly and easily. To create a form using the Form Wizard, you can follow these 

steps: 

1. From the File menu, select New and then Form. 

2. In the Form Wizard dialog box, select the table or query that you want to use 

as the data source for the form. 

3. Select the fields that you want to include in the form and arrange them in the 

order that you want them to appear. 

4. Select the layout and style for the form, such as the font, color, and alignment. 

5. Select any controls, such as buttons, labels, or checkboxes, that you want to 

include in the form. 

6. Preview the form and make any necessary adjustments. 

7. Save the form and give it a name. 

It's worth mentioning that Visual FoxPro 6.0 is an old version and is not supported 

anymore. If you are planning to work with form wizard, it's recommended to use a 

more recent version of Visual FoxPro or other development environments that have 

more advanced features and support. 

 

 

create a label using the label wizard 

 

The Label Wizard is a tool in Visual FoxPro 6.0 that helps you to create labels 

quickly and easily. To create a label using the Label Wizard, you can follow these 

steps: 

1. From the File menu, select New and then Label. 

2. In the Label Wizard dialog box, select the table or query that you want to use 

as the data source for the label. 

3. Select the fields that you want to include in the label and arrange them in the 

order that you want them to appear. 

4. Select the layout and style for the label, such as the font, color, and alignment. 

5. Select any filters or calculated fields that you want to include in the label. 

6. Preview the label and make any necessary adjustments. 

7. Save the label and give it a name. 
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It's worth mentioning that Visual FoxPro 6.0 is an old version and is not supported 

anymore. If you are planning to work with label wizard, it's recommended to use a 

more recent version of Visual FoxPro or other development environments that have 

more advanced features and support. 

 

create a query using the wizard 

 

The Query Wizard is a tool in Visual FoxPro 6.0 that helps you to create queries 

quickly and easily. To create a query using the Query Wizard, you can follow these 

steps: 

1. From the File menu, select New and then Query. 

2. In the Query Wizard dialog box, select the table or tables that you want to 

include in the query. 

3. Select the fields that you want to include in the query and arrange them in the 

order that you want them to appear. 

4. Select any sorting or filtering options that you want to apply to the query. 

5. Select any calculated fields or expressions that you want to include in the 

query. 

6. Preview the query and make any necessary adjustments. 

7. Save the query and give it a name. 

It's worth mentioning that Visual FoxPro 6.0 is an old version and is not supported 

anymore. If you are planning to work with query wizard, it's recommended to use a 

more recent version of Visual FoxPro or other development environments that have 

more advanced features and support. 

Mail Merge Wizard 

The Mail Merge Wizard is a feature in Visual FoxPro 6.0 that allows you to create 

mass mailings by merging data from a table or a query with a document template. 

The resulting documents can be either printed or exported to electronic formats such 

as email or PDF. The Mail Merge Wizard can be used to create a variety of 

documents, including letters, labels, envelopes, and email messages. 

To use the Mail Merge Wizard, you will need to have a document template that 

contains merge fields, which are placeholders for the data that will be inserted from 

the table or query. You can also create a new document from scratch and insert the 

merge fields. 

The steps to use the Mail Merge Wizard are as follows: 
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1. Open Visual FoxPro 6.0 and create or open the document template that you 

want to use for the mail merge. The template should contain merge fields, 

which are placeholders for the data that will be inserted from the table or 

query. 

2. Select File > New > Mailing Labels or File > New > Mailing Letters to start 

the Mail Merge Wizard. 

3. In the first step of the wizard, select the data source for the mail merge. You 

can choose to use data from an existing table or query, or you can create a new 

query. 

4. In the next step, select the fields that you want to include in the merge. You 

can choose to include all fields or select specific fields. 

5. The next step allows you to preview the merge results and make any necessary 

adjustments to the data. 

6. In the final step, you can merge the data with the document template to create 

the final documents. You can choose to print the documents or export them to 

electronic formats such as email or PDF. 

7. Once the merge is complete, you can save the merge template and use it again 

for future mail merge projects. 

Visual FoxPro 6.0 is an old version and is not supported anymore. If you are planning 

to work with Mail merge wizard, it's recommended to use a more recent version of 

Visual FoxPro or other development environments that have more advanced features 

and support. 

 

Sorting and indexing 

Sorting and indexing are important techniques for organizing and optimizing the 

performance of data in Visual FoxPro 6.0. 

Sorting is the process of arranging the records in a table in a specific order based on 

one or more fields. You can use the SET ORDER TO command to sort a table based 

on a specific field or field. The syntax for the SET ORDER TO command is SET 

ORDER TO fieldname [ASCENDING | DESCENDING]. For example, SET 

ORDER TO LastName ASCENDING will sort the table by the LastName field in 

ascending order. 

Indexing is the process of creating an index on one or more fields of a table. An 

index is a data structure that allows for faster searching and sorting of data. When 

you create an index on a field, Visual FoxPro creates a separate data file that contains 
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a sorted list of the values in that field, along with the record numbers of the 

corresponding records in the table. You can use the INDEX ON command to create 

an index on a specific field or field. The syntax for the INDEX ON command is 

INDEX ON fieldname TO indexname. For example, INDEX ON LastName TO 

LastNameIndex will create an index on the LastName field and name it 

"LastNameIndex". 

It's worth noting that in Visual FoxPro 6.0, indexes are not automatically maintained. 

You may need to use the REINDEX command to rebuild the indexes if the data in 

the table changes. 

 

 Questions on Visual Foxpro 6.0 programming 

1. What is the syntax for declaring variables in Visual FoxPro 6.0? 

2. How do you create a new form in Visual FoxPro 6.0? 

3. What are the different types of cursors used in Visual FoxPro 6.0? 

4. How do you create a new table in Visual FoxPro 6.0? 

5. How do you add a new record to a table in Visual FoxPro 6.0? 

6. What is the function to open a table in Visual FoxPro 6.0? 

7. How do you create a new index in Visual FoxPro 6.0? 

8. What is the syntax for writing a query in Visual FoxPro 6.0? 

9. How do you create a new report in Visual FoxPro 6.0? 

10. How do you use the Debugger in Visual FoxPro 6.0? 

11. What are the different types of triggers supported in Visual FoxPro 6.0? 

12. How do you create a new class in Visual FoxPro 6.0? 

13. What is the syntax for creating a new method in a class in Visual FoxPro 6.0? 

14. How do you create a new project in Visual FoxPro 6.0? 

15. How do you create a new program in Visual FoxPro 6.0? 

16. What is the command to open a table in Visual FoxPro 6.0? 

17. How can you filter records in a table in Visual FoxPro 6.0? 
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18. What is the command to create a new index in Visual FoxPro 6.0? 

19. How can you sort records in a table in Visual FoxPro 6.0? 

20. What is the command to run a query in Visual FoxPro 6.0? 

21. How can you add a new record to a table in Visual FoxPro 6.0? 

22. What is the command to delete a record from a table in Visual FoxPro 6.0? 

23. How can you modify the structure of a table in Visual FoxPro 6.0? 

24. What is the command to create a new form in Visual FoxPro 6.0? 

25. How can you copy data from one table to another in Visual FoxPro 6.0? 

26. What is the command to run a program in Visual FoxPro 6.0? 

27. How can you export data to a file in Visual FoxPro 6.0? 

28. What is the command to create a new class in Visual FoxPro 6.0? 

29. How can you import data from a file into a table in Visual FoxPro 6.0? 

30. What is the command to create a new report in Visual FoxPro 6.0? 

 

 


